BETA

15th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/12/17 03:01 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 03:02 PM]