BETA

15th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/12/17 02:59 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 03:00 PM]