BETA

15th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [15/12/17 02:50 PM] with 'Major Outage'

Issue has been resolved at [15/12/17 02:52 PM]