BETA

15th December 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [15/12/17 12:33 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 12:34 PM]