BETA

15th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [15/12/17 09:30 AM] with 'Partial Outage'

Issue has been resolved at [15/12/17 09:33 AM]