BETA

15th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/12/17 01:36 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 02:00 AM]