BETA

15th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [15/12/17 01:30 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 02:03 AM]