BETA

15th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/12/17 01:29 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/12/17 01:32 AM]