BETA

23rd June 2016

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/06/16 12:06 AM] with 'Partial Outage'

Issue has been resolved at [23/06/16 12:10 AM]