BETA

15th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/12/17 01:23 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 01:24 AM]