BETA

15th December 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [15/12/17 01:22 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 01:24 AM]