BETA

15th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/12/17 01:12 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 01:21 AM]