BETA

15th December 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [15/12/17 01:11 AM] with 'Major Outage'

Issue has been resolved at [15/12/17 01:20 AM]