BETA

14th December 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [14/12/17 11:54 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 12:04 AM]