BETA

14th December 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [14/12/17 11:43 PM] with 'Major Outage'

Issue has been resolved at [15/12/17 02:03 AM]