BETA

4th February 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [04/02/17 08:17 AM] with 'Partial Outage'

Issue has been resolved at [04/02/17 08:22 AM]