BETA

14th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/12/17 11:40 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/12/17 12:46 AM]