BETA

14th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [14/12/17 11:36 PM] with 'Partial Outage'

Issue has been resolved at [14/12/17 11:37 PM]