BETA

4th February 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [04/02/17 08:08 AM] with 'Partial Outage'

Issue has been resolved at [07/02/17 02:00 AM]