BETA

14th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/12/17 11:27 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/12/17 11:30 PM]