BETA

14th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/12/17 01:13 PM] with 'Major Outage'

Issue has been resolved at [14/12/17 01:14 PM]