BETA

14th December 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/12/17 01:04 PM] with 'Major Outage'

Issue has been resolved at [14/12/17 01:07 PM]