BETA

14th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/12/17 12:50 PM] with 'Major Outage'

Issue has been resolved at [14/12/17 12:51 PM]