BETA

14th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [14/12/17 12:48 PM] with 'Major Outage'

Issue has been resolved at [14/12/17 12:58 PM]