BETA

14th December 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/12/17 11:52 AM] with 'Partial Outage'

Issue has been resolved at [14/12/17 11:55 AM]