BETA

14th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/12/17 10:57 AM] with 'Major Outage'

Issue has been resolved at [14/12/17 11:01 AM]