BETA

14th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/12/17 10:46 AM] with 'Major Outage'

Issue has been resolved at [14/12/17 10:47 AM]