BETA

14th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/12/17 10:39 AM] with 'Major Outage'

Issue has been resolved at [14/12/17 10:40 AM]