BETA

14th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [14/12/17 10:39 AM] with 'Partial Outage'

Issue has been resolved at [14/12/17 11:11 AM]