BETA

13th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/12/17 04:32 PM] with 'Major Outage'

Issue has been resolved at [13/12/17 04:33 PM]