BETA

12th December 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/12/17 12:53 PM] with 'Major Outage'

Issue has been resolved at [12/12/17 12:54 PM]