BETA

2nd January 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/01/17 09:16 AM] with 'Partial Outage'

Issue has been resolved at [02/01/17 09:27 AM]