BETA

1st January 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [01/01/17 07:35 PM] with 'Partial Outage'

Issue has been resolved at [01/01/17 07:44 PM]