BETA

31st December 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [31/12/16 09:30 AM] with 'Partial Outage'

Issue has been resolved at [31/12/16 09:43 AM]