BETA

29th December 2016

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/12/16 09:16 AM] with 'Major Outage'

Issue has been resolved at [29/12/16 09:26 AM]