BETA

12th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/12/17 09:16 AM] with 'Partial Outage'

Issue has been resolved at [12/12/17 09:19 AM]