BETA

20th June 2016

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [20/06/16 07:28 AM] with 'Major Outage'

Issue has been resolved at [20/06/16 07:40 AM]