BETA

12th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/12/17 08:47 AM] with 'Partial Outage'

Issue has been resolved at [12/12/17 08:48 AM]