BETA

26th December 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [26/12/16 05:21 PM] with 'Partial Outage'

Issue has been resolved at [26/12/16 06:03 PM]