BETA

12th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/12/17 08:19 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [12/12/17 08:21 AM]