BETA

13th March 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [13/03/19 05:35 PM] with 'Partial Outage'

Issue has been resolved at [13/03/19 05:36 PM]