BETA

20th December 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [20/12/16 12:24 AM] with 'Major Outage'

Issue has been resolved at [20/12/16 12:33 AM]