BETA

12th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/12/17 07:36 AM] with 'Major Outage'

Issue has been resolved at [12/12/17 07:40 AM]