BETA

20th June 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [20/06/16 07:27 AM] with 'Major Outage'

Issue has been resolved at [20/06/16 07:40 AM]