BETA

12th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/12/17 07:26 AM] with 'Partial Outage'

Issue has been resolved at [12/12/17 07:27 AM]