BETA

13th December 2016

West Bengal Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/12/16 12:58 PM] with 'Partial Outage'

Issue has been resolved at [13/12/16 01:05 PM]