BETA

13th December 2016

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [13/12/16 01:40 AM] with 'Partial Outage'

Issue has been resolved at [13/12/16 02:00 AM]