BETA

12th December 2016

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [12/12/16 12:54 PM] with 'Major Outage'

Issue has been resolved at [14/12/16 12:12 PM]