BETA

13th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/03/19 05:12 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/03/19 05:24 PM]