BETA

20th June 2016

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [20/06/16 07:26 AM] with 'Major Outage'

Issue has been resolved at [20/06/16 07:32 AM]